Square is experiencing Degraded Performance
Incident Report for Resova
Resolved
Square states that All Systems Operational
Posted Sep 08, 2023 - 23:39 BST
Monitoring
Square is experiencing Degraded Performance and may affect payments. Please check their status page for updates. https://www.issquareup.com/
Posted Sep 07, 2023 - 21:55 BST