Service Disruption: Card Acceptance with Square Payments in Great Britain
Incident Report for Resova
Resolved
Our Operations team has verified that services with Square Payments UK are now working as expected. For more information, please visit https://uk.issquareup.com/.

If you have any questions, you can reach out to our Support team at https://help.resova.com.
Posted Mar 05, 2022 - 22:31 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 05, 2022 - 16:26 GMT
Identified
Square Payments in Great Britain are currently experiencing issues when accepting card payments. For more information, please visit the Square UK Status Page at https://uk.issquareup.com/.
Posted Mar 05, 2022 - 16:25 GMT
This incident affected: Integrations (Square Payments).